OpenIndiana 2015.10, continua il sogno di OpenSolaris

openindianaE’ disponibile un nuovo aggiornamento di OpenIndiana, il sistema operativo basato su Illumos che deriva da ciò che fu la code-base di OpenSolaris prima di essere uccisa da Oracle.

Il nome di questa nuova release è OpenIndiana 2015.10 “Hipster”.

Con questa versione, il sistema di packaging IPS è stato aggiornato con delle fix e alcune funzionalità nuove. E’ stato anche predisposto il supporto a boot loaders non-GRUB, e l’installer testuale ha visto alcuni aggiornamenti poiché è scritto in Python, mentre l’installer GUI scritto in C non viene più mantenuto ed è in programma di rimuoverlo del tutto nella prossima release se nessuno si offrirà di mantenerlo. Un altro aggiornamento significativo in questo OS derivato da OpenSolaris è costituito dalla completa rimozione dell’ambiente Java Sun JDK/JRE in favore dell’utilizzo del codice OpenJDK, che è maggiormente aperto.

openindiana-2015-10-hipster

Alcuni degli aggiornamenti ai pacchetti di OpenIndiana 2015.10 includono Perl 5.22, Qt 4.8.7, GCC 4.8.5, Compiz 0.8.10, PulseAudio 1.1, X.Org Server 1.14.7, Mesa 10.5.9, e Joyent’s KVM 20150903. Alcune di queste versioni sono lontane dall’essere le più recenti, come ad esempio il server X.Org, PulseAudio e Mesa, a causa di problemi di compatibilità con (Open)Solaris. Lo stack grafico allo stato attuale è arretrato a causa della mancanza di supporto al kernel mode-setting per gpu Radeon, il quale è richiesto dalle ultime release di Radeon DDX che di converso supportano le release moderne del server X.Org. Il miglior supporto grafico per OpenIndiana rimane quello di NVIDIA quando si utilizza il loro driver proprietario; il driver NVIDIA 340.93 viene fornito direttamente insieme a questa release.

La versione di Firefox inclusa è la 24.8.1 poiché la versione più recente ha dei problemi su OpenIndiana con il supporto dei plugin. La suite di OpenOffice.org non è funzionante ma le note di rilascio raccomandano di installare LibreOffice dal repository SFE. Il desktop di default è GNOME 2.32 con Compiz.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

 
Login with:
Powered by Sociable!